ramips: add support for Linksys RE7000
[openwrt/openwrt.git] / target / linux / ramips / image / mt7621.mk
index d33937a8d743e88708ed805d9c4cb0e5fcaafa2b..582d53c4230c63ec135350021054ea05b4b3de3d 100644 (file)
@@ -1541,6 +1541,15 @@ define Device/linksys_re6500
 endef
 TARGET_DEVICES += linksys_re6500
 
+define Device/linksys_re7000
+  $(Device/uimage-lzma-loader)
+  IMAGE_SIZE := 16064k
+  DEVICE_VENDOR := Linksys
+  DEVICE_MODEL := RE7000
+  DEVICE_PACKAGES := kmod-mt7603 kmod-mt7615-firmware
+endef
+TARGET_DEVICES += linksys_re7000
+
 define Device/mediatek_ap-mt7621a-v60
   $(Device/dsa-migration)
   IMAGE_SIZE := 7872k