ramips: add support for ASUS RT-AC1200-V2
[openwrt/openwrt.git] / target / linux / ramips / image / mt76x8.mk
index bd91bd9340c8b1053ec41a268000366ce33026d2..81b68f63540827a785945eba36d1406055b913a8 100644 (file)
@@ -47,6 +47,19 @@ define Device/asus_rt-ac1200
 endef
 TARGET_DEVICES += asus_rt-ac1200
 
+define Device/asus_rt-ac1200-v2
+  BLOCKSIZE := 64k
+  IMAGE_SIZE := 16064k
+  DEVICE_VENDOR := Asus
+  DEVICE_MODEL := RT-AC1200
+  DEVICE_VARIANT := V2
+  IMAGES += factory.bin
+  IMAGE/factory.bin := append-kernel | pad-to $$$$(BLOCKSIZE) | \
+       append-rootfs | pad-rootfs
+  DEVICE_PACKAGES := kmod-mt7615e kmod-mt7663-firmware-ap
+endef
+TARGET_DEVICES += asus_rt-ac1200-v2
+
 define Device/asus_rt-n10p-v3
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := Asus