ramips: set default BLOCKSIZE to 64k for nor flash devices
[openwrt/openwrt.git] / target / linux / ramips / image / rt305x.mk
index 92cc9094a8bab3be22fdfb49b9d3cf7b7a731a7c..83658cffa2d24ad34790c487a9c999d5c3f54910 100644 (file)
@@ -67,7 +67,6 @@ TARGET_DEVICES += accton_wr6202
 
 define Device/airlive_air3gii
   SOC := rt5350
 
 define Device/airlive_air3gii
   SOC := rt5350
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := AirLive
   DEVICE_MODEL := Air3GII
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := AirLive
   DEVICE_MODEL := Air3GII
@@ -174,7 +173,6 @@ TARGET_DEVICES += argus_atp-52b
 
 define Device/asiarf_awapn2403
   SOC := rt3052
 
 define Device/asiarf_awapn2403
   SOC := rt3052
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := AsiaRF
   DEVICE_MODEL := AWAPN2403
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := AsiaRF
   DEVICE_MODEL := AWAPN2403
@@ -208,7 +206,6 @@ TARGET_DEVICES += asiarf_awm002-evb-8m
 
 define Device/asus_rt-g32-b1
   SOC := rt3050
 
 define Device/asus_rt-g32-b1
   SOC := rt3050
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := RT-G32
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := RT-G32
@@ -220,7 +217,6 @@ TARGET_DEVICES += asus_rt-g32-b1
 
 define Device/asus_rt-n10-plus
   SOC := rt3050
 
 define Device/asus_rt-n10-plus
   SOC := rt3050
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := RT-N10+
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := RT-N10+
@@ -241,7 +237,6 @@ TARGET_DEVICES += asus_rt-n13u
 
 define Device/asus_wl-330n
   SOC := rt3050
 
 define Device/asus_wl-330n
   SOC := rt3050
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := WL-330N
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := WL-330N
@@ -252,7 +247,6 @@ TARGET_DEVICES += asus_wl-330n
 
 define Device/asus_wl-330n3g
   SOC := rt3050
 
 define Device/asus_wl-330n3g
   SOC := rt3050
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := WL-330N3G
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ASUS
   DEVICE_MODEL := WL-330N3G
@@ -305,7 +299,6 @@ TARGET_DEVICES += belkin_f7c027
 
 define Device/buffalo_whr-g300n
   SOC := rt3052
 
 define Device/buffalo_whr-g300n
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3712k
   DEVICE_VENDOR := Buffalo
   DEVICE_MODEL := WHR-G300N
   IMAGE_SIZE := 3712k
   DEVICE_VENDOR := Buffalo
   DEVICE_MODEL := WHR-G300N
@@ -371,7 +364,6 @@ TARGET_DEVICES += dlink_dir-300-b1
 
 define Device/dlink_dir-300-b7
   SOC := rt5350
 
 define Device/dlink_dir-300-b7
   SOC := rt5350
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DIR-300
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := D-Link
   DEVICE_MODEL := DIR-300
@@ -407,7 +399,6 @@ TARGET_DEVICES += dlink_dir-600-b1
 define Device/dlink_dir-610-a1
   $(Device/seama)
   SOC := rt5350
 define Device/dlink_dir-610-a1
   $(Device/seama)
   SOC := rt5350
-  BLOCKSIZE := 4k
   SEAMA_SIGNATURE := wrgn59_dlob.hans_dir610
   KERNEL := $(KERNEL_DTB)
   IMAGE_SIZE := 3776k
   SEAMA_SIGNATURE := wrgn59_dlob.hans_dir610
   KERNEL := $(KERNEL_DTB)
   IMAGE_SIZE := 3776k
@@ -436,7 +427,6 @@ TARGET_DEVICES += dlink_dir-615-d
 define Device/dlink_dir-615-h1
   $(Device/uimage-lzma-loader)
   SOC := rt3352
 define Device/dlink_dir-615-h1
   $(Device/uimage-lzma-loader)
   SOC := rt3352
-  BLOCKSIZE := 4k
   IMAGES += factory.bin
   IMAGE_SIZE := 3776k
   IMAGE/factory.bin := $$(sysupgrade_bin) | senao-header -r 0x218 -p 0x30 -t 3
   IMAGES += factory.bin
   IMAGE_SIZE := 3776k
   IMAGE/factory.bin := $$(sysupgrade_bin) | senao-header -r 0x218 -p 0x30 -t 3
@@ -525,7 +515,6 @@ TARGET_DEVICES += edimax_3g-6200nl
 
 define Device/engenius_esr-9753
   SOC := rt3052
 
 define Device/engenius_esr-9753
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := EnGenius
   DEVICE_MODEL := ESR-9753
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := EnGenius
   DEVICE_MODEL := ESR-9753
@@ -549,7 +538,6 @@ TARGET_DEVICES += fon_fonera-20n
 
 define Device/hame_mpr-a1
   SOC := rt5350
 
 define Device/hame_mpr-a1
   SOC := rt5350
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 3776k
   UIMAGE_NAME:= Linux Kernel Image
   DEVICE_VENDOR := HAME
   IMAGE_SIZE := 3776k
   UIMAGE_NAME:= Linux Kernel Image
   DEVICE_VENDOR := HAME
@@ -609,7 +597,6 @@ TARGET_DEVICES += hootoo_ht-tm02
 
 define Device/huawei_d105
   SOC := rt3050
 
 define Device/huawei_d105
   SOC := rt3050
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Huawei
   DEVICE_MODEL := D105
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Huawei
   DEVICE_MODEL := D105
@@ -810,7 +797,6 @@ TARGET_DEVICES += omnima_miniembwifi
 
 define Device/petatel_psr-680w
   SOC := rt3052
 
 define Device/petatel_psr-680w
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Petatel
   DEVICE_MODEL := PSR-680W Wireless 3G Router
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Petatel
   DEVICE_MODEL := PSR-680W Wireless 3G Router
@@ -821,7 +807,6 @@ TARGET_DEVICES += petatel_psr-680w
 
 define Device/planex_mzk-dp150n
   SOC := rt5350
 
 define Device/planex_mzk-dp150n
   SOC := rt5350
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Planex
   DEVICE_MODEL := MZK-DP150N
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Planex
   DEVICE_MODEL := MZK-DP150N
@@ -943,7 +928,6 @@ TARGET_DEVICES += prolink_pwh2004
 
 define Device/ralink_v22rw-2x2
   SOC := rt3052
 
 define Device/ralink_v22rw-2x2
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Ralink
   DEVICE_MODEL := AP-RT3052-V22RW-2X2
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Ralink
   DEVICE_MODEL := AP-RT3052-V22RW-2X2
@@ -954,7 +938,6 @@ TARGET_DEVICES += ralink_v22rw-2x2
 
 define Device/sitecom_wl-351
   SOC := rt3052
 
 define Device/sitecom_wl-351
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Sitecom
   DEVICE_MODEL := WL-351 v1
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Sitecom
   DEVICE_MODEL := WL-351 v1
@@ -966,7 +949,6 @@ TARGET_DEVICES += sitecom_wl-351
 
 define Device/skyline_sl-r7205
   SOC := rt3052
 
 define Device/skyline_sl-r7205
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Skyline
   DEVICE_MODEL := SL-R7205 Wireless 3G Router
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Skyline
   DEVICE_MODEL := SL-R7205 Wireless 3G Router
@@ -977,7 +959,6 @@ TARGET_DEVICES += skyline_sl-r7205
 
 define Device/sparklan_wcr-150gn
   SOC := rt3050
 
 define Device/sparklan_wcr-150gn
   SOC := rt3050
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Sparklan
   DEVICE_MODEL := WCR-150GN
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Sparklan
   DEVICE_MODEL := WCR-150GN
@@ -997,7 +978,6 @@ TARGET_DEVICES += teltonika_rut5xx
 
 define Device/tenda_3g150b
   SOC := rt5350
 
 define Device/tenda_3g150b
   SOC := rt5350
-  BLOCKSIZE := 4k
   IMAGE_SIZE := 3776k
   UIMAGE_NAME:= Linux Kernel Image
   DEVICE_VENDOR := Tenda
   IMAGE_SIZE := 3776k
   UIMAGE_NAME:= Linux Kernel Image
   DEVICE_VENDOR := Tenda
@@ -1045,7 +1025,6 @@ TARGET_DEVICES += tenda_w306r-v2
 
 define Device/trendnet_tew-638apb-v2
   SOC := rt3050
 
 define Device/trendnet_tew-638apb-v2
   SOC := rt3050
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   IMAGE/sysupgrade.bin := $$(sysupgrade_bin) | umedia-header 0x026382 | \
        check-size | append-metadata
   IMAGE_SIZE := 3776k
   IMAGE/sysupgrade.bin := $$(sysupgrade_bin) | umedia-header 0x026382 | \
        check-size | append-metadata
@@ -1103,7 +1082,6 @@ TARGET_DEVICES += unbranded_wr512-3gn-8m
 
 define Device/unbranded_xdx-rn502j
   SOC := rt3052
 
 define Device/unbranded_xdx-rn502j
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Unbranded
   DEVICE_MODEL := XDX-RN502J
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := Unbranded
   DEVICE_MODEL := XDX-RN502J
@@ -1114,7 +1092,6 @@ TARGET_DEVICES += unbranded_xdx-rn502j
 
 define Device/upvel_ur-326n4g
   SOC := rt3052
 
 define Device/upvel_ur-326n4g
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := UPVEL
   DEVICE_MODEL := UR-326N4G
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := UPVEL
   DEVICE_MODEL := UR-326N4G
@@ -1197,7 +1174,6 @@ TARGET_DEVICES += zte_mf283plus
 
 define Device/zyxel_keenetic
   SOC := rt3052
 
 define Device/zyxel_keenetic
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := Keenetic
   IMAGE_SIZE := 7872k
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := Keenetic
@@ -1238,7 +1214,6 @@ TARGET_DEVICES += zyxel_keenetic-start
 
 define Device/zyxel_nbg-419n
   SOC := rt3052
 
 define Device/zyxel_nbg-419n
   SOC := rt3052
-  BLOCKSIZE := 64k
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := NBG-419N
   IMAGE_SIZE := 3776k
   DEVICE_VENDOR := ZyXEL
   DEVICE_MODEL := NBG-419N