ramips: add LinkIt Smart7688 support
[openwrt/openwrt.git] / target / linux / ramips / mt7688 / profiles / 01-mediatek.mk
index 02190dd3ab581e6738e2c08ce79f12fbe261019b..0e24e0686c74d404bb6f19401fba758ad6381f7e 100644 (file)
@@ -16,3 +16,15 @@ define Profile/mt7688/Description
        Default package set compatible with most boards.
 endef
 $(eval $(call Profile,mt7688))
+
+define Profile/LinkIt7688
+       NAME:=LinkIt7688
+       PACKAGES:=\
+               kmod-usb-core kmod-usb2 kmod-usb-ohci \
+               uboot-envtools kmod-ledtrig-netdev
+endef
+
+define Profile/LinkIt7688/Description
+       Default package set compatible with LinkIt Smart7688 dev board.
+endef
+$(eval $(call Profile,LinkIt7688))