some platform support path name cleanup
[openwrt/openwrt.git] / target / linux / rb532-2.6 / image / Makefile
index 1f3a88ba4049a5240a99e7032a70d84b47c764ef..4e1c1addd15518a18b1d9bea8f104805358f0eef 100644 (file)
@@ -25,7 +25,7 @@ define Build/Compile
 endef
 
 define Build/Clean
-       $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean
+       $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean
 endef
 
 define Image/Prepare
@@ -35,7 +35,7 @@ endef
 
 define Image/BuildKernel
        cat $(KDIR)/vmlinux | $(STAGING_DIR)/bin/lzma e -si -so -eos -lc1 -lp2 -pb2 > $(KDIR)/vmlinux.lzma
-       $(MAKE) -C ../../generic-2.6/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
+       $(MAKE) -C $(GENERIC_PLATFORM_DIR)/image/lzma-loader $(LOADER_MAKEOPTS) clean compile
        $(CP) $(KDIR)/loader.elf $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-vmlinux
 endef