rtl838x: d-link_dgs-1210: refactor common family bits
[openwrt/openwrt.git] / target / linux / rtl838x / image / Makefile
index f490fa7ffe92fa446962cbdbb7db3c63215fbd73..cd384c53452240b3c03e17863881c19998f50630 100644 (file)
@@ -41,22 +41,24 @@ define Device/allnet_all-sg8208m
 endef
 TARGET_DEVICES += allnet_all-sg8208m
 
-define Device/d-link_dgs-1210-16
+define Device/d-link_dgs-1210
   SOC := rtl8382
   IMAGE_SIZE := 13824k
   DEVICE_VENDOR := D-Link
-  DEVICE_MODEL := DGS-1210-16
   DEVICE_PACKAGES := ip-full ip-bridge ethtool tc
 endef
-TARGET_DEVICES += d-link_dgs-1210-16
 
 define Device/d-link_dgs-1210-10p
-  SOC := rtl8382
-  IMAGE_SIZE := 13824k
-  DEVICE_VENDOR := D-Link
+  $(Device/d-link_dgs-1210)
   DEVICE_MODEL := DGS-1210-10P
-  DEVICE_PACKAGES := ip-full ip-bridge ethtool tc lua-rs232
+  DEVICE_PACKAGES += lua-rs232
 endef
 TARGET_DEVICES += d-link_dgs-1210-10p
 
+define Device/d-link_dgs-1210-16
+  $(Device/d-link_dgs-1210)
+  DEVICE_MODEL := DGS-1210-16
+endef
+TARGET_DEVICES += d-link_dgs-1210-16
+
 $(eval $(call BuildImage))