realtek: update the tree to the latest refactored version
[openwrt/openwrt.git] / target / linux / rtl838x / patches-5.4 / 400-mtd-add-rtl838x-spi-flash-driver.patch
diff --git a/target/linux/rtl838x/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch b/target/linux/rtl838x/patches-5.4/400-mtd-add-rtl838x-spi-flash-driver.patch
deleted file mode 100644 (file)
index 16cff75..0000000
+++ /dev/null
@@ -1,23 +0,0 @@
---- a/drivers/mtd/spi-nor/Kconfig
-+++ b/drivers/mtd/spi-nor/Kconfig
-@@ -118,4 +118,13 @@ config SPI_INTEL_SPI_PLATFORM
-         To compile this driver as a module, choose M here: the module
-         will be called intel-spi-platform.
-+config SPI_RTL838X
-+      tristate "Realtek RTl838X SPI flash platform driver"
-+      depends on RTL838X
-+      help
-+        This driver provides support for accessing SPI flash
-+        in the RTL838X SoC.
-+
-+        Say N here unless you know what you are doing.
-+
- endif # MTD_SPI_NOR
---- a/drivers/mtd/spi-nor/Makefile
-+++ b/drivers/mtd/spi-nor/Makefile
-@@ -8,3 +8,4 @@ obj-$(CONFIG_SPI_NXP_SPIFI)    += nxp-spifi
- obj-$(CONFIG_SPI_INTEL_SPI)   += intel-spi.o
- obj-$(CONFIG_SPI_INTEL_SPI_PCI)       += intel-spi-pci.o
- obj-$(CONFIG_SPI_INTEL_SPI_PLATFORM)  += intel-spi-platform.o
-+obj-$(CONFIG_SPI_RTL838X)     += rtl838x-nor.o