sunxi: tidy up and sort alphabetically in image Makefiles
[openwrt/openwrt.git] / target / linux / sunxi / image / Makefile
index 888c1c5a9ba31cab493b36dfc593f7dabd846a0e..705d409ac5e5e8e81c8b39055554e6b19be4acb6 100644 (file)
@@ -42,8 +42,16 @@ define Device/Default
   SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
 endef
 
+ifeq ($(SUBTARGET),cortexa7)
 include cortex-a7.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa8)
 include cortex-a8.mk
+endif
+
+ifeq ($(SUBTARGET),cortexa53)
 include cortex-a53.mk
+endif
 
 $(eval $(call BuildImage))