sunxi: rename SUNXI_SOC to SOC
[openwrt/openwrt.git] / target / linux / sunxi / image / Makefile
index 929f4c70f98330504e53a5c6b1b42e52bf662d7c..888c1c5a9ba31cab493b36dfc593f7dabd846a0e 100644 (file)
@@ -32,15 +32,14 @@ endef
 # why \x00\x00\x00\x00 for zImage-initramfs
 define Device/Default
   PROFILES := Default
-  DEVICE_VARS := SUNXI_SOC SUNXI_DTS SUNXI_DTS_DIR SUNXI_UBOOT
+  DEVICE_VARS := SUNXI_DTS SUNXI_DTS_DIR SUNXI_UBOOT
   KERNEL_NAME := zImage
   KERNEL := kernel-bin | uImage none
   IMAGES := sdcard.img.gz
   IMAGE/sdcard.img.gz := sunxi-sdcard | append-metadata | gzip
   SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
-  SUNXI_SOC :=
   SUNXI_DTS_DIR :=
-  SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SUNXI_SOC)-$(lastword $(subst _, ,$(1)))
+  SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
 endef
 
 include cortex-a7.mk