sunxi: add support for NanoPi M1 Plus board
[openwrt/openwrt.git] / target / linux / sunxi / image / cortex-a7.mk
index d219a1d097a3d108eb64e555f2782b061886eb0f..229b055e688b1fbfbb3a4260bbb28dabc5afca90 100644 (file)
@@ -118,6 +118,18 @@ endef
 TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
 
 
 TARGET_DEVICES += sun8i-h2-plus-orangepi-r1
 
 
+define Device/sun8i-h3-nanopi-m1-plus
+  DEVICE_TITLE:=FriendlyArm NanoPi M1 Plus
+  DEVICE_PACKAGES:=kmod-rtc-sunxi \
+       kmod-leds-gpio kmod-ledtrig-heartbeat \
+       kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-mini
+  SUPPORTED_DEVICES:=friendlyarm,nanopi-m1-plus
+  SUNXI_DTS:=sun8i-h3-nanopi-m1-plus
+endef
+
+TARGET_DEVICES += sun8i-h3-nanopi-m1-plus
+
+
 define Device/sun8i-h3-nanopi-neo
   DEVICE_TITLE:=FriendlyARM NanoPi NEO
   SUPPORTED_DEVICES:=friendlyarm,nanopi-neo
 define Device/sun8i-h3-nanopi-neo
   DEVICE_TITLE:=FriendlyARM NanoPi NEO
   SUPPORTED_DEVICES:=friendlyarm,nanopi-neo