sunxi: rename SUNXI_SOC to SOC
[openwrt/openwrt.git] / target / linux / sunxi / image / cortex-a7.mk
index 83b313a3781c7a5b22a3dec9b995c4c2e3f5b28d..3dad8b19b442339eb10594cff6793e41f45f28d1 100644 (file)
@@ -12,7 +12,7 @@ define Device/olimex_a20-olinuxino-lime
   DEVICE_VENDOR := Olimex
   DEVICE_MODEL := A20-OLinuXino-LIME
   DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi
-  SUNXI_SOC := sun7i
+  SOC := sun7i
 endef
 
 TARGET_DEVICES += olimex_a20-olinuxino-lime
@@ -22,7 +22,7 @@ define Device/olimex_a20-olinuxino-lime2
   DEVICE_VENDOR := Olimex
   DEVICE_MODEL := A20-OLinuXino-LIME2
   DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
-  SUNXI_SOC := sun7i
+  SOC := sun7i
 endef
 
 TARGET_DEVICES += olimex_a20-olinuxino-lime2
@@ -33,7 +33,7 @@ define Device/olimex_a20-olinuxino-lime2-emmc
   DEVICE_MODEL := A20-OLinuXino-LIME2
   DEVICE_VARIANT := eMMC
   DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-usb-hid
-  SUNXI_SOC := sun7i
+  SOC := sun7i
 endef
 
 TARGET_DEVICES += olimex_a20-olinuxino-lime2-emmc
@@ -43,7 +43,7 @@ define Device/olimex_a20-olinuxino-micro
   DEVICE_VENDOR := Olimex
   DEVICE_MODEL := A20-OLinuXino-MICRO
   DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
-  SUNXI_SOC := sun7i
+  SOC := sun7i
 endef
 
 TARGET_DEVICES += olimex_a20-olinuxino-micro
@@ -53,7 +53,7 @@ define Device/lemaker_bananapi
   DEVICE_VENDOR := LeMaker
   DEVICE_MODEL := Banana Pi
   DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
-  SUNXI_SOC := sun7i-a20
+  SOC := sun7i-a20
 endef
 
 TARGET_DEVICES += lemaker_bananapi
@@ -63,7 +63,7 @@ define Device/lemaker_bananapro
   DEVICE_VENDOR := LeMaker
   DEVICE_MODEL := Banana Pro
   DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi kmod-brcmfmac
-  SUNXI_SOC := sun7i-a20
+  SOC := sun7i-a20
 endef
 
 TARGET_DEVICES += lemaker_bananapro
@@ -73,7 +73,7 @@ define Device/cubietech_cubieboard2
   DEVICE_VENDOR := Cubietech
   DEVICE_MODEL := Cubieboard2
   DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-sun4i-emac kmod-rtc-sunxi
-  SUNXI_SOC := sun7i-a20
+  SOC := sun7i-a20
 endef
 
 TARGET_DEVICES += cubietech_cubieboard2
@@ -83,7 +83,7 @@ define Device/cubietech_cubietruck
   DEVICE_VENDOR := Cubietech
   DEVICE_MODEL := Cubietruck
   DEVICE_PACKAGES:=kmod-ata-core kmod-ata-sunxi kmod-rtc-sunxi kmod-brcmfmac
-  SUNXI_SOC := sun7i-a20
+  SOC := sun7i-a20
 endef
 
 TARGET_DEVICES += cubietech_cubietruck
@@ -93,7 +93,7 @@ define Device/lamobo_lamobo-r1
   DEVICE_VENDOR := Lamobo
   DEVICE_MODEL := Lamobo R1
   DEVICE_PACKAGES:=kmod-ata-sunxi kmod-rtl8192cu swconfig wpad-basic
-  SUNXI_SOC := sun7i-a20
+  SOC := sun7i-a20
 endef
 
 TARGET_DEVICES += lamobo_lamobo-r1
@@ -103,7 +103,7 @@ define Device/mele_m9
   DEVICE_VENDOR := Mele
   DEVICE_MODEL := M9
   DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-rtl8192cu
-  SUNXI_SOC := sun6i-a31
+  SOC := sun6i-a31
 endef
 
 TARGET_DEVICES += mele_m9
@@ -113,7 +113,7 @@ define Device/xunlong_orangepi-zero
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi Zero
   DEVICE_PACKAGES:=kmod-rtc-sunxi
-  SUNXI_SOC := sun8i-h2-plus
+  SOC := sun8i-h2-plus
 endef
 
 TARGET_DEVICES += xunlong_orangepi-zero
@@ -123,7 +123,7 @@ define Device/xunlong_orangepi-r1
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi R1
   DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-usb-net kmod-usb-net-rtl8152
-  SUNXI_SOC := sun8i-h2-plus
+  SOC := sun8i-h2-plus
 endef
 
 TARGET_DEVICES += xunlong_orangepi-r1
@@ -134,7 +134,7 @@ define Device/sinovoip_bananapi-m2-plus
   DEVICE_PACKAGES:=kmod-rtc-sunxi \
        kmod-leds-gpio kmod-ledtrig-heartbeat \
        kmod-brcmfmac brcmfmac-firmware-43430a0-sdio wpad-basic
-  SUNXI_SOC := sun8i-h3
+  SOC := sun8i-h3
 endef
 
 TARGET_DEVICES += sinovoip_bananapi-m2-plus
@@ -145,7 +145,7 @@ define Device/friendlyarm_nanopi-m1-plus
   DEVICE_PACKAGES:=kmod-rtc-sunxi \
        kmod-leds-gpio kmod-ledtrig-heartbeat \
        kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
-  SUNXI_SOC := sun8i-h3
+  SOC := sun8i-h3
 endef
 
 TARGET_DEVICES += friendlyarm_nanopi-m1-plus
@@ -154,7 +154,7 @@ TARGET_DEVICES += friendlyarm_nanopi-m1-plus
 define Device/friendlyarm_nanopi-neo
   DEVICE_VENDOR := FriendlyARM
   DEVICE_MODEL := NanoPi NEO
-  SUNXI_SOC := sun8i-h3
+  SOC := sun8i-h3
 endef
 
 TARGET_DEVICES += friendlyarm_nanopi-neo
@@ -166,7 +166,7 @@ define Device/friendlyarm_nanopi-neo-air
   DEVICE_PACKAGES := kmod-rtc-sunxi \
         kmod-leds-gpio kmod-ledtrig-heartbeat \
         kmod-brcmfmac brcmfmac-firmware-43430-sdio wpad-basic
-  SUNXI_SOC := sun8i-h3
+  SOC := sun8i-h3
 endef
 
 TARGET_DEVICES += friendlyarm_nanopi-neo-air
@@ -176,7 +176,7 @@ define Device/xunlong_orangepi-one
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi One
   DEVICE_PACKAGES:=kmod-rtc-sunxi
-  SUNXI_SOC := sun8i-h3
+  SOC := sun8i-h3
 endef
 
 TARGET_DEVICES += xunlong_orangepi-one
@@ -186,7 +186,7 @@ define Device/xunlong_orangepi-pc
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi PC
   DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
-  SUNXI_SOC := sun8i-h3
+  SOC := sun8i-h3
 endef
 
 TARGET_DEVICES += xunlong_orangepi-pc
@@ -196,7 +196,7 @@ define Device/xunlong_orangepi-pc-plus
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi PC Plus
   DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
-  SUNXI_SOC := sun8i-h3
+  SOC := sun8i-h3
 endef
 
 TARGET_DEVICES += xunlong_orangepi-pc-plus
@@ -206,7 +206,7 @@ define Device/xunlong_orangepi-plus
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi Plus
   DEVICE_PACKAGES:=kmod-rtc-sunxi
-  SUNXI_SOC := sun8i-h3
+  SOC := sun8i-h3
 endef
 
 TARGET_DEVICES += xunlong_orangepi-plus
@@ -215,7 +215,7 @@ define Device/xunlong_orangepi-2
   DEVICE_VENDOR := Xunlong
   DEVICE_MODEL := Orange Pi 2
   DEVICE_PACKAGES:=kmod-rtc-sunxi
-  SUNXI_SOC := sun8i-h3
+  SOC := sun8i-h3
 endef
 
 TARGET_DEVICES += xunlong_orangepi-2
@@ -225,7 +225,7 @@ define Device/linksprite_pcduino3
   DEVICE_VENDOR := LinkSprite
   DEVICE_MODEL := pcDuino3
   DEVICE_PACKAGES:=kmod-sun4i-emac kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi kmod-rtl8xxxu rtl8188eu-firmware
-  SUNXI_SOC := sun7i-a20
+  SOC := sun7i-a20
 endef
 
 TARGET_DEVICES += linksprite_pcduino3
@@ -234,7 +234,7 @@ define Device/lemaker_bananapi-m2-ultra
   DEVICE_VENDOR := LeMaker
   DEVICE_MODEL := Banana Pi M2 Ultra
   DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-ata-core kmod-ata-sunxi
-  SUNXI_SOC := sun8i-r40
+  SOC := sun8i-r40
 endef
 
 TARGET_DEVICES += lemaker_bananapi-m2-ultra