sunxi: Add support for Xunlong Orange Pi PC
[openwrt/openwrt.git] / target / linux / sunxi / image / cortex-a7.mk
index 229b055e688b1fbfbb3a4260bbb28dabc5afca90..986b6395c4bd21c7c2519e09867b374a2803c2a1 100644 (file)
@@ -139,6 +139,16 @@ endef
 TARGET_DEVICES += sun8i-h3-nanopi-neo
 
 
+define Device/sun8i-h3-orangepi-pc
+  DEVICE_TITLE:=Xunlong Orange Pi PC
+  DEVICE_PACKAGES:=kmod-rtc-sunxi kmod-gpio-button-hotplug
+  SUPPORTED_DEVICES:=xunlong,orangepi-pc
+  SUNXI_DTS:=sun8i-h3-orangepi-pc
+endef
+
+TARGET_DEVICES += sun8i-h3-orangepi-pc
+
+
 define Device/sun8i-h3-orangepi-plus
   DEVICE_TITLE:=Xunlong Orange Pi Plus
   DEVICE_PACKAGES:=kmod-rtc-sunxi