sunxi: add sunxi-ir module
[openwrt/openwrt.git] / target / linux / sunxi / modules.mk
index a8339211caf391e2ba1b270a68558595c53c5d20..a4c71b9b8645886b3e63a6fd35aaca124c3d9bc7 100644 (file)
@@ -22,6 +22,26 @@ endef
 
 $(eval $(call KernelPackage,rtc-sunxi))
 
+define KernelPackage/sunxi-ir
+    SUBMENU:=$(OTHER_MENU)
+    TITLE:=Sunxi SoC built-in IR support (A20)
+    DEPENDS:=@TARGET_sunxi +kmod-input-core
+    $(call AddDepends/rtc)
+    KCONFIG:= \
+       CONFIG_MEDIA_SUPPORT=y \
+       CONFIG_MEDIA_RC_SUPPORT=y \
+       CONFIG_RC_DEVICES=y \
+       CONFIG_IR_SUNXI
+    FILES:=$(LINUX_DIR)/drivers/media/rc/sunxi-cir.ko
+    AUTOLOAD:=$(call AutoLoad,50,sunxi-cir)
+endef
+
+define KernelPackage/sunxi-ir/description
+ Support for the AllWinner sunXi SoC's onboard IR (A20)
+endef
+
+$(eval $(call KernelPackage,sunxi-ir))
+
 define KernelPackage/eeprom-sunxi
     SUBMENU:=$(OTHER_MENU)
     TITLE:=AllWinner Security ID fuse support