target/sunxi: add dependency on sunxi to kmod-wdt-sunxi
[openwrt/openwrt.git] / target / linux / sunxi / modules.mk
index 374cef2b1795ca6aa4c3a99ac0ffbe903db7fedf..a8339211caf391e2ba1b270a68558595c53c5d20 100644 (file)
@@ -70,6 +70,7 @@ $(eval $(call KernelPackage,sun4i-emac))
 define KernelPackage/wdt-sunxi
     SUBMENU:=$(OTHER_MENU)
     TITLE:=AllWinner sunXi Watchdog timer
+    DEPENDS:=@TARGET_sunxi
     KCONFIG:=CONFIG_SUNXI_WATCHDOG
     FILES:=$(LINUX_DIR)/drivers/$(WATCHDOG_DIR)/sunxi_wdt.ko
     AUTOLOAD:=$(call AutoLoad,51,sunxi_wdt)