x86: add genisoimage and xorrisofs as alternatives to mkisofs
[openwrt/openwrt.git] / target / linux / x86 / Makefile
index 045d043e4d850fa71eca0ade50051034ad507dea..1b8d45f32aeea3e98a45403135a1bb226450237b 100644 (file)
@@ -23,6 +23,9 @@ DEFAULT_PACKAGES += partx-utils mkf2fs e2fsprogs
 
 $(eval $(call BuildTarget))
 
-$(eval $(call $(if $(CONFIG_ISO_IMAGES),RequireCommand,Ignore),mkisofs, \
-       Please install mkisofs. \
+$(eval $(call $(if $(CONFIG_ISO_IMAGES),SetupHostCommand,Ignore),mkisofs, \
+       Please install mkisofs. , \
+       mkisofs -v 2>&1 , \
+       genisoimage -v 2>&1 | grep genisoimage, \
+       xorrisofs -v 2>&1 | grep xorriso \
 ))