zynq: derive DEVICE_DTS from device definition name
[openwrt/openwrt.git] / target / linux / zynq / image / Makefile
index 39305a6d5435d0c1e725d235fc79fe937812fe61..7cec38ca687c1d2df7d8020613a5101a1af7883d 100644 (file)
@@ -31,6 +31,7 @@ endef
 
 define Device/Default
        PROFILES := Default
+       DEVICE_DTS := $(lastword $(subst _, ,$(1)))
        KERNEL_DEPENDS = $$(wildcard $(DTS_DIR)/$$(DEVICE_DTS).dts)
        KERNEL_INITRAMFS_PREFIX := $$(IMG_PREFIX)-$(1)-initramfs
        KERNEL_PREFIX := $$(IMAGE_PREFIX)
@@ -53,7 +54,6 @@ define Device/avnet_zynq-zed
        $(call Device/FitImageGzip)
        DEVICE_VENDOR := Avnet
        DEVICE_MODEL := ZedBoard
-       DEVICE_DTS := zynq-zed
 endef
 TARGET_DEVICES += avnet_zynq-zed
 
@@ -61,7 +61,6 @@ define Device/digilent_zynq-zybo
        $(call Device/FitImageGzip)
        DEVICE_VENDOR := Digilent
        DEVICE_MODEL := Zybo
-       DEVICE_DTS := zynq-zybo
 endef
 TARGET_DEVICES += digilent_zynq-zybo
 
@@ -69,7 +68,6 @@ define Device/digilent_zynq-zybo-z7
        $(call Device/FitImageGzip)
        DEVICE_VENDOR := Digilent
        DEVICE_MODEL := Zybo Z7
-       DEVICE_DTS := zynq-zybo-z7
 endef
 TARGET_DEVICES += digilent_zynq-zybo-z7
 
@@ -77,7 +75,6 @@ define Device/xlnx_zynq-zc702
        $(call Device/FitImageGzip)
        DEVICE_VENDOR := Xilinx
        DEVICE_MODEL := ZC702
-       DEVICE_DTS := zynq-zc702
        DEVICE_PACKAGES:=kmod-can kmod-can-xilinx-can
 endef
 TARGET_DEVICES += xlnx_zynq-zc702