sdk: bundle usbip userspace sources
[openwrt/openwrt.git] / target / sdk / Makefile
index d3822a0df60bb4aa8c3d285a24253aebc1482a9f..499c2809dd2c3c1e18367b8a61fde4dfdc1a0abd 100644 (file)
@@ -84,6 +84,10 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
                $(SDK_DIRS) $(KERNEL_FILES) | \
                $(TAR) -xf - -C $(SDK_BUILD_DIR)
 
+       # Copy usbip sources, this is required for the usbip userspace packages to be buildable by the SDK.
+       $(TAR) -cf - -C $(TOPDIR) $(KDIR_BASE)/tools/usb/usbip/ | \
+               $(TAR) -xf - -C $(SDK_BUILD_DIR)
+
        (cd $(SDK_BUILD_DIR); find $(STAGING_SUBDIR_HOST)/bin $(STAGING_SUBDIR_HOST)/usr/bin \
                $(STAGING_SUBDIR_TOOLCHAIN)/bin $(STAGING_SUBDIR_TOOLCHAIN)/*/bin $(STAGING_SUBDIR_TOOLCHAIN)/libexec \
                -type f | $(XARGS) $(SCRIPT_DIR)/bundle-libraries.sh $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST))