toolchain: gcc: enable sanitizers for glibc toolchain
[openwrt/openwrt.git] / toolchain / gcc / final / Makefile
index b815f677d669c8cac479d365f52449f64564637c..0315b9d1f163b9d61c48929360763a82b7263602 100644 (file)
@@ -4,7 +4,6 @@ include ../common.mk
 
 GCC_CONFIGURE += \
        --with-headers=$(TOOLCHAIN_DIR)/include \
-       --disable-libsanitizer \
        --enable-languages=$(TARGET_LANGUAGES) \
        --enable-shared \
        --enable-threads \
@@ -12,6 +11,10 @@ GCC_CONFIGURE += \
        --enable-lto \
        --with-libelf=$(TOPDIR)/staging_dir/host
 
+ifndef CONFIG_USE_GLIBC
+  GCC_CONFIGURE += --disable-libsanitizer
+endif
+
 ifdef CONFIG_USE_MUSL
   GCC_MAKE += gcc_cv_libc_provides_ssp=yes
 endif