toolchain: gcc: add support for GCC 13
[openwrt/openwrt.git] / toolchain / gcc / patches-13.x / 820-libgcc_pic.patch
index 525a95b565704d134e12b76a480cb06b1744dbfa..7d102981904fcd917f0c4b69e986c4a49b621a31 100644 (file)
@@ -8,7 +8,7 @@ Date:   Mon Oct 19 23:26:09 2009 +0000
 
 --- a/libgcc/Makefile.in
 +++ b/libgcc/Makefile.in
-@@ -930,11 +930,12 @@ $(libgcov-driver-objects): %$(objext): $
+@@ -933,11 +933,12 @@ $(libgcov-driver-objects): %$(objext): $
  
  # Static libraries.
  libgcc.a: $(libgcc-objects)
@@ -22,7 +22,7 @@ Date:   Mon Oct 19 23:26:09 2009 +0000
        -rm -f $@
  
        objects="$(objects)";                                   \
-@@ -958,7 +959,7 @@ all: libunwind.a
+@@ -961,7 +962,7 @@ all: libunwind.a
  endif
  
  ifeq ($(enable_shared),yes)
@@ -31,7 +31,7 @@ Date:   Mon Oct 19 23:26:09 2009 +0000
  ifneq ($(LIBUNWIND),)
  all: libunwind$(SHLIB_EXT)
  libgcc_s$(SHLIB_EXT): libunwind$(SHLIB_EXT)
-@@ -1164,6 +1165,10 @@ install-shared:
+@@ -1167,6 +1168,10 @@ install-shared:
        chmod 644 $(DESTDIR)$(inst_libdir)/libgcc_eh.a
        $(RANLIB) $(DESTDIR)$(inst_libdir)/libgcc_eh.a