nasm: disable LTO, remove host specific workarounds
[openwrt/openwrt.git] / toolchain / nasm / Makefile
index 31166358fd963ec01240bf8a4b97d65b7ce4cbc0..53b7848caf7409d191ec061451063c04ba8c305b 100644 (file)
@@ -19,17 +19,11 @@ include $(INCLUDE_DIR)/toolchain-build.mk
 HOST_CONFIGURE_ARGS+= \
                --target=$(REAL_GNU_TARGET_NAME) \
                --with-sysroot=$(TOOLCHAIN_DIR) \
-               --enable-lto \
+               --disable-lto \
                --disable-werror \
                --disable-gdb \
                $(SOFT_FLOAT_CONFIG_OPTION) \
 
-ifeq ($(HOST_OS),Darwin)
-       HOST_MAKE_FLAGS = \
-               AR=ar \
-               RANLIB=ranlib
-endif
-
 define Host/Prepare
        $(call Host/Prepare/Default)
        ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)