uclibc: make powerpc e500 support independent of the target name, always use it if...
[openwrt/openwrt.git] / toolchain / uClibc / Makefile
index 21a180c22551d50ee8e67fd505042234676b9e6d..d74d1ecfc836dfb9ab05714f8d70bcf665f51e05 100644 (file)
@@ -59,7 +59,9 @@ endef
 GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
        $(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) \
        $(if $(CONFIG_UCLIBC_ENABLE_DEBUG),$(if $(wildcard $(CONFIG_DIR)/debug),'+' $(CONFIG_DIR)/debug)) \
 GEN_CONFIG=$(SCRIPT_DIR)/kconfig.pl -n \
        $(if $(wildcard $(CONFIG_DIR)/common),'+' $(CONFIG_DIR)/common) \
        $(if $(CONFIG_UCLIBC_ENABLE_DEBUG),$(if $(wildcard $(CONFIG_DIR)/debug),'+' $(CONFIG_DIR)/debug)) \
-       $(CONFIG_DIR)/$(ARCH)$(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD))
+       $(CONFIG_DIR)/$(ARCH)$(strip \
+               $(if $(wildcard $(CONFIG_DIR)/$(ARCH).$(BOARD)),.$(BOARD), \
+                       $(if $(CONFIG_HAS_SPE_FPU),$(if $(wildcard $(CONFIG_DIR)/$(ARCH).e500),.e500))))
 
 define Host/Prepare
        $(call Host/Prepare/Default)
 
 define Host/Prepare
        $(call Host/Prepare/Default)