toolchain: add support of ARC architecture
[openwrt/openwrt.git] / toolchain / uClibc / common.mk
index 895022ce6002d0f3ff2e94633ce37f534631234c..3d0a501247b3ea00d1e949e285f5857e77cca37e 100644 (file)
@@ -23,6 +23,7 @@ HOST_BUILD_DIR:=$(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)-$(PKG_VERSION)
 include $(INCLUDE_DIR)/toolchain-build.mk
 
 UCLIBC_TARGET_ARCH:=$(shell echo $(ARCH) | sed -e s'/-.*//' \
+               -e 's/arc.*/arc/' \
                -e 's/i.86/i386/' \
                -e 's/sparc.*/sparc/' \
                -e 's/arm.*/arm/g' \