uClibc: add another missing backport patch
[openwrt/openwrt.git] / toolchain / uClibc / patches-0.9.33.2 / 020-add-posix_madvise.c.patch
diff --git a/toolchain/uClibc/patches-0.9.33.2/020-add-posix_madvise.c.patch b/toolchain/uClibc/patches-0.9.33.2/020-add-posix_madvise.c.patch
deleted file mode 100644 (file)
index 2b18c25..0000000
+++ /dev/null
@@ -1,48 +0,0 @@
-From: "Peter S. Mazinger" <ps.m@gmx.net>
-Date: Tue, 26 Apr 2011 23:03:44 +0200
-Subject: [PATCH] add posix_madvise.c
-
-Signed-off-by: Peter S. Mazinger <ps.m@gmx.net>
-Signed-off-by: Bernhard Reutner-Fischer <rep.dot.nop@gmail.com>
----
- create mode 100644 libc/sysdeps/linux/common/posix_madvise.c
-
---- a/libc/sysdeps/linux/common/Makefile.in
-+++ b/libc/sysdeps/linux/common/Makefile.in
-@@ -81,7 +81,7 @@ CSRC-$(UCLIBC_HAS_REALTIME) += clock_get
-       sched_get_priority_max.c sched_get_priority_min.c sched_getscheduler.c \
-       sched_rr_get_interval.c sched_setparam.c sched_setscheduler.c sigqueue.c
- # clock_getcpuclockid|clock_nanosleep|mq_timedreceive|mq_timedsend|posix_fadvise|posix_fallocate|posix_madvise|posix_memalign|posix_mem_offset|posix_spawnattr_destroy|posix_spawnattr_init|posix_spawnattr_getflags|posix_spawnattr_setflags|posix_spawnattr_getpgroup|posix_spawnattr_setpgroup|posix_spawnattr_getschedparam|posix_spawnattr_setschedparam|posix_spawnattr_getschedpolicy|posix_spawnattr_setschedpolicy|posix_spawnattr_getsigdefault|posix_spawnattr_setsigdefault|posix_spawnattr_getsigmask|posix_spawnattr_setsigmask|posix_spawnattr_init|posix_spawnattr_setflags|posix_spawnattr_setpgroup|posix_spawnattr_setschedparam|posix_spawnattr_setschedpolicy|posix_spawnattr_setsigdefault|posix_spawnattr_setsigmask|posix_spawn_file_actions_addclose|posix_spawn_file_actions_addopen|posix_spawn_file_actions_adddup2|posix_spawn_file_actions_addopen|posix_spawn_file_actions_destroy|posix_spawn_file_actions_init|posix_spawn_file_actions_init|posix_spawn|posix_spawnp|posix_spawnp|posix_typed_mem_get_info|pthread_mutex_timedlock|sem_timedwait
--CSRC-$(UCLIBC_HAS_ADVANCED_REALTIME) += posix_fadvise64.c posix_fadvise.c
-+CSRC-$(UCLIBC_HAS_ADVANCED_REALTIME) += posix_fadvise64.c posix_fadvise.c posix_madvise.c
- CSRC-$(UCLIBC_SUSV4_LEGACY) += utime.c
- CSRC-$(UCLIBC_HAS_EPOLL) += epoll.c
- CSRC-$(UCLIBC_HAS_XATTR) += xattr.c
---- /dev/null
-+++ b/libc/sysdeps/linux/common/posix_madvise.c
-@@ -0,0 +1,25 @@
-+/* vi: set sw=4 ts=4: */
-+/* Licensed under the LGPL v2.1, see the file LICENSE in this tarball. */
-+
-+#include <sys/mman.h>
-+#include <sys/syscall.h>
-+
-+#if defined __NR_madvise && defined __USE_XOPEN2K && defined __UCLIBC_HAS_ADVANCED_REALTIME__
-+int posix_madvise(void *addr, size_t len, int advice)
-+{
-+      int result;
-+      /* We have one problem: the kernel's MADV_DONTNEED does not
-+       * correspond to POSIX's POSIX_MADV_DONTNEED.  The former simply
-+       * discards changes made to the memory without writing it back to
-+       * disk, if this would be necessary.  The POSIX behaviour does not
-+       * allow this.  There is no functionality mapping for the POSIX
-+       * behaviour so far so we ignore that advice for now. */
-+      if (advice == POSIX_MADV_DONTNEED)
-+              return 0;
-+
-+      /* this part might use madvise function */
-+      INTERNAL_SYSCALL_DECL (err);
-+      result = INTERNAL_SYSCALL (madvise, err, 3, addr, len, advice);
-+      return INTERNAL_SYSCALL_ERRNO (result, err);
-+}
-+#endif