uClibc: split the package into the main directory and the headers/ and utils/ subdire...
[openwrt/openwrt.git] / toolchain / uClibc / utils / Makefile
diff --git a/toolchain/uClibc/utils/Makefile b/toolchain/uClibc/utils/Makefile
new file mode 100644 (file)
index 0000000..d9efda0
--- /dev/null
@@ -0,0 +1,24 @@
+PATH_PREFIX=..
+
+include ../common.mk
+
+HOST_STAMP_BUILT:=$(HOST_BUILD_DIR)/.utils_built
+HOST_STAMP_INSTALLED:=$(TOOLCHAIN_DIR)/stamp/.uclibc_utils_installed
+
+define Host/Compile
+       $(SED) 's,^CROSS=.*,CROSS=$(TARGET_CROSS),g' $(HOST_BUILD_DIR)/Rules.mak
+       $(UCLIBC_MAKE) $(TOOLCHAIN_JOBS) PREFIX= utils
+endef
+
+define Host/Install
+       $(INSTALL_DIR) $(TOOLCHAIN_DIR)/bin
+       $(INSTALL_BIN) \
+               $(HOST_BUILD_DIR)/utils/ldd \
+               $(TOOLCHAIN_DIR)/bin/
+       $(INSTALL_DIR) $(TOOLCHAIN_DIR)/sbin
+       $(INSTALL_BIN) \
+               $(HOST_BUILD_DIR)/utils/ldconfig \
+               $(TOOLCHAIN_DIR)/sbin/
+endef
+
+$(eval $(call HostBuild))