make libtool a tool build and let autoconf depend on it
[openwrt/openwrt.git] / tools / libtool / Makefile
diff --git a/tools/libtool/Makefile b/tools/libtool/Makefile
new file mode 100644 (file)
index 0000000..82730df
--- /dev/null
@@ -0,0 +1,34 @@
+# 
+# Copyright (C) 2008 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libtool
+PKG_VERSION:=2.4
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=b32b04148ecdd7344abc6fe8bd1bb021
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR)
+endef
+
+define Host/Install
+       $(MAKE) -C $(HOST_BUILD_DIR) install
+       $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(STAGING_DIR_HOST)/bin/libtool
+       $(CP) $(STAGING_DIR_HOST)/bin/libtool $(STAGING_DIR_HOST)/bin/libtool-ucxx
+       $(SED) 's,-lstdc++,-luClibc++,g' $(STAGING_DIR_HOST)/bin/libtool-ucxx
+endef
+
+define Host/Clean
+       -$(MAKE) -C $(HOST_BUILD_DIR) uninstall
+       $(call Host/Clean/Default)
+endef
+
+$(eval $(call HostBuild))