tools/mkimage: update to 2021.10
[openwrt/openwrt.git] / tools / mkimage / Makefile
index 1eb713a22ada764dc95dc357a9023bd936617d1b..5ed4107e1d6b4b62f84f996dc58211a0ef088ade 100644 (file)
@@ -7,14 +7,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=mkimage
-PKG_VERSION:=2021.01
+PKG_VERSION:=2021.10
 
 PKG_SOURCE:=u-boot-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_URL:= \
        https://mirror.cyberbits.eu/u-boot \
        https://ftp.denx.de/pub/u-boot \
        ftp://ftp.denx.de/pub/u-boot
-PKG_HASH:=b407e1510a74e863b8b5cb42a24625344f0e0c2fc7582d8c866bd899367d0454
+PKG_HASH:=cde723e19262e646f2670d25e5ec4b1b368490de950d4e26275a988c36df0bd4
 
 HOST_BUILD_DIR:=$(BUILD_DIR_HOST)/u-boot-$(PKG_VERSION)
 
@@ -38,6 +38,7 @@ define Host/Compile
                CONFIG_FIT=y \
                CONFIG_FIT_SIGNATURE=y \
                CONFIG_FIT_SIGNATURE_MAX_SIZE=0x10000000 \
+               CONFIG_TOOLS_LIBCRYPTO=y \
                tools-only
 endef