use HOST_STATIC_LINKING instead of hardcoding -static
[openwrt/openwrt.git] / tools / mklibs / Makefile
index 0858ad3d501739f0dffaba932fc43b5b74d446bb..fd3d233c4700600526c7d195ebcbec3e51e2be53 100644 (file)
@@ -16,7 +16,7 @@ PKG_MD5SUM:=afe0ed527ba96b8a882b5de350603007
 include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CFLAGS += -I$(CURDIR)/include
-HOST_LDFLAGS += -static
+HOST_LDFLAGS += $(HOST_STATIC_LINKING)
 
 define Host/Install
        $(INSTALL_BIN) \