add mktools and dosfstools which are needed for the raspberry pi
[openwrt/openwrt.git] / tools / mtools / Makefile
diff --git a/tools/mtools/Makefile b/tools/mtools/Makefile
new file mode 100644 (file)
index 0000000..994ca8d
--- /dev/null
@@ -0,0 +1,31 @@
+# 
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=mtools
+PKG_VERSION:=4.0.17
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
+PKG_SOURCE_URL:=@GNU/$(PKG_NAME)
+PKG_MD5SUM:=231741ac95802d03aa32f44edb768171
+PKG_CAT:=zcat
+
+include $(INCLUDE_DIR)/host-build.mk
+
+define Host/Compile
+       $(MAKE) -C $(HOST_BUILD_DIR) mcopy
+endef
+
+define Host/Install
+       $(INSTALL_BIN) $(HOST_BUILD_DIR)/mcopy $(STAGING_DIR_HOST)/bin/
+endef
+
+define Host/Clean
+       rm -f $(STAGING_DIR_HOST)/bin/mcopy
+endef
+
+$(eval $(call HostBuild))