quilt: fix building with dash `test x == x` gives a syntax error with dash (standard...
[openwrt/openwrt.git] / tools / quilt / patches / 100-patch_2.6.1_version.patch
index 84f275318c5107b76236f4a9986626aae4a84181..1e9ed75df1c7951d99ae1192f86790a6821defc1 100644 (file)
@@ -1,11 +1,15 @@
 --- a/configure.ac
 +++ b/configure.ac
-@@ -274,7 +274,7 @@ fi
+@@ -274,7 +274,11 @@ fi
  AC_MSG_CHECKING([the version of $PATCH])
  if $PATCH --version 2> /dev/null | grep GNU >/dev/null; then
    set -- `$PATCH --version 2> /dev/null`
 -  patch_version=$2
-+  test $2 == "patch" && patch_version=$3 || patch_version=$2
++  if test x$1 = xGNU ; then
++    patch_version=$3
++  else
++    patch_version=$2
++  fi
    AC_MSG_RESULT($patch_version)
    saved_IFS=$IFS; IFS='.'
    set -- $patch_version