added unsquashfs-lzma, usefull for debugging of existing fs images
[openwrt/openwrt.git] / tools / squashfs / patches / 100-lzma.patch
index 85aa21fb92f6a87e7302ca01955961f28923035b..34fdcad18baeb858f5af14c45d5ae6559aabe2b7 100644 (file)
@@ -1,6 +1,5 @@
-diff -Nur squashfs3.0/squashfs-tools/Makefile squashfs3.0-owrt/squashfs-tools/Makefile
---- squashfs3.0/squashfs-tools/Makefile        2006-03-15 22:36:20.000000000 +0100
-+++ squashfs3.0-owrt/squashfs-tools/Makefile   2006-03-21 11:14:08.000000000 +0100
+--- a/squashfs-tools/Makefile
++++ b/squashfs-tools/Makefile
 @@ -1,4 +1,5 @@
  INCLUDEDIR = .
 +#LZMAPATH = ../lzma/SRC/7zip/Compress/LZMA_Lib
@@ -17,9 +16,13 @@ diff -Nur squashfs3.0/squashfs-tools/Makefile squashfs3.0-owrt/squashfs-tools/Ma
  mksquashfs.o: mksquashfs.c squashfs_fs.h mksquashfs.h global.h sort.h
  
  read_fs.o: read_fs.c squashfs_fs.h read_fs.h global.h
-@@ -17,3 +21,5 @@
+@@ -16,4 +20,9 @@
+ unsquashfs: unsquashfs.o
        $(CC) unsquashfs.o -lz -o $@
  
++unsquashfs-lzma: unsquashfs.o
++      $(CXX) unsquashfs.o -L$(LZMAPATH) -llzma -o $@
++
  unsquashfs.o: unsquashfs.c squashfs_fs.h read_fs.h global.h
 +
 +clean: