tools: add tar host build, required for --sort=name which was only added in the lates...
[openwrt/openwrt.git] / tools / tar / Makefile
diff --git a/tools/tar/Makefile b/tools/tar/Makefile
new file mode 100644 (file)
index 0000000..975e783
--- /dev/null
@@ -0,0 +1,30 @@
+#
+# Copyright (C) 2015 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=tar
+PKG_VERSION:=1.28
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.xz
+PKG_SOURCE_URL:=@GNU/tar
+PKG_MD5SUM:=49b6306167724fe48f419a33a5beb857
+
+HOST_BUILD_PARALLEL := 1
+
+include $(INCLUDE_DIR)/host-build.mk
+
+HOSTCC := $(HOSTCC_NOCACHE)
+HOSTCXX := $(HOSTCXX_NOCACHE)
+
+HOST_CONFIGURE_ARGS += \
+       --without-posix-acls \
+       --without-selinux \
+       --without-xattrs \
+       --disable-acl \
+       --disable-nls
+
+$(eval $(call HostBuild))