tools/xz: disable shared library
[openwrt/openwrt.git] / tools / xz / Makefile
index e266667957852c8f3769ea97e9cb5d5206a2d7a6..d1f10081aebc55d5a877a3295ec61af0ecd32635 100644 (file)
@@ -17,6 +17,10 @@ HOST_BUILD_PARALLEL:=1
 
 include $(INCLUDE_DIR)/host-build.mk
 
 
 include $(INCLUDE_DIR)/host-build.mk
 
+HOST_CONFIGURE_ARGS += \
+       --enable-static=yes \
+       --enable-shared=no \
+
 define Host/Install
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef
 define Host/Install
        +$(MAKE) $(HOST_JOBS) -C $(HOST_BUILD_DIR) install xzlinks="unxz xzcat"
 endef