rb532: align partitions to 128KB
[openwrt/staging/blogic.git] / target / linux / rb532 / image / Makefile
index 706c768060a8f3be1d0cc26d6c2a795ad2a8a9c5..284b3d45105676b3a8a7544bafc04fc567425f72 100644 (file)
@@ -63,10 +63,18 @@ define Image/cmdline/yaffs2
 root=/dev/mtdblock1 rootfstype=yaffs2
 endef
 
+define Image/Build/squashfs
+       $(call prepare_generic_squashfs,$(KDIR)/root.squashfs)
+endef
+
 define Image/Build
+       $(call Image/Build/$(1),$(1))
        $(CP) $(KDIR)/vmlinux.elf $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel
        $(STAGING_DIR_HOST)/bin/patch-cmdline $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel '$(strip $(call Image/cmdline/$(1))) '
-       ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).bin 4 $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1)
+       ./gen_image.sh $(BIN_DIR)/$(IMG_PREFIX)-combined-$(1).bin \
+               4 $(BIN_DIR)/$(IMG_PREFIX)-$(1).kernel \
+               $(CONFIG_TARGET_ROOTFS_PARTSIZE) $(KDIR)/root.$(1) \
+               128
 endef
 
 $(eval $(call BuildImage))