build: disable CONFIG_AUTOREMOVE for packages/tools where QUILT is used
[openwrt/staging/chunkeey.git] / include / host-build.mk
index cf1203995c422cc7e21d5889a7343c797a17b295..6a335fcbc3b1fe62e4b18f7e2f7f1b590e8b1c1c 100644 (file)
@@ -35,6 +35,8 @@ override MAKEFLAGS=
 include $(INCLUDE_DIR)/quilt.mk
 include $(INCLUDE_DIR)/autotools.mk
 
+_host_target:=$(if $(HOST_QUILT),,.)
+
 Host/Patch:=$(Host/Patch/Default)
 ifneq ($(strip $(HOST_UNPACK)),)
   define Host/Prepare/Default
@@ -176,9 +178,9 @@ ifndef DUMP
     )
   endif
 
-  .host-prepare: $(HOST_STAMP_PREPARED)
-  .host-configure: $(HOST_STAMP_CONFIGURED)
-  .host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
+  $(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
+  $(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
+  $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
   host-clean: FORCE
        $(call Host/Clean)
        $(call Host/Uninstall)