build: fix CONFIG_AUTOREMOVE for packages with multiple variants
[openwrt/staging/chunkeey.git] / include / host-build.mk
index 6a335fcbc3b1fe62e4b18f7e2f7f1b590e8b1c1c..d96cc94fa3c6d12f6eb2cf5c95579497a314e8d5 100644 (file)
@@ -176,15 +176,20 @@ ifndef DUMP
       $(t): host-$(t)
       .$(t): .host-$(t)
     )
+    clean-build: host-clean-build
   endif
 
   $(_host_target)host-prepare: $(HOST_STAMP_PREPARED)
   $(_host_target)host-configure: $(HOST_STAMP_CONFIGURED)
   $(_host_target)host-compile: $(HOST_STAMP_BUILT) $(HOST_STAMP_INSTALLED)
-  host-clean: FORCE
+
+  host-clean-build: FORCE
+       rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_BUILT)
+
+  host-clean: host-clean-build
        $(call Host/Clean)
        $(call Host/Uninstall)
-       rm -rf $(HOST_BUILD_DIR) $(HOST_STAMP_INSTALLED) $(HOST_STAMP_BUILT)
+       rm -rf $(HOST_STAMP_INSTALLED)
 
     ifneq ($(CONFIG_AUTOREMOVE),)
       host-compile: