build: image: use UTC for zip timestamp
[openwrt/staging/chunkeey.git] / include / image-commands.mk
index 939f5ef2db4db7afeab6f0009d926aef3055d906..21f851d2054fb2494bce35f4ae43c74f56fb9ce8 100644 (file)
@@ -541,8 +541,7 @@ define Build/zip
        rm -rf $@.tmp
        mkdir $@.tmp
        mv $@ $@.tmp/$(word 1,$(1))
-
-       $(STAGING_DIR_HOST)/bin/zip -j -X \
+       TZ=UTC $(STAGING_DIR_HOST)/bin/zip -j -X \
                $(if $(SOURCE_DATE_EPOCH),--mtime="$(SOURCE_DATE_EPOCH)") \
                $(wordlist 2,$(words $(1)),$(1)) \
                $@ $@.tmp/$(if $(word 1,$(1)),$(word 1,$(1)),$$(basename $@))