image: drop unused 'BuildKernel/MkFIT'
[openwrt/staging/chunkeey.git] / include / image.mk
index b23e192c5d0c3e678f369bf65ce6562d83586a83..bdcf20d30c70a7229d4f0ecc6f80e6d90197fcb6 100644 (file)
@@ -137,14 +137,6 @@ define Image/BuildKernel/MkuImage
                -n '$(call toupper,$(ARCH)) $(VERSION_DIST) Linux-$(LINUX_VERSION)' -d $(4) $(5)
 endef
 
-define Image/BuildKernel/MkFIT
-       $(TOPDIR)/scripts/mkits.sh \
-               -D $(1) -o $(KDIR)/fit-$(1).its -k $(2) $(if $(3),-d $(3)) -C $(4) -a $(5) -e $(6) \
-               -c $(if $(DEVICE_DTS_CONFIG),$(DEVICE_DTS_CONFIG),"config-1") \
-               -A $(LINUX_KARCH) -v $(LINUX_VERSION)
-       PATH=$(LINUX_DIR)/scripts/dtc:$(PATH) mkimage -f $(KDIR)/fit-$(1).its $(KDIR)/fit-$(1)$(7).itb
-endef
-
 ifdef CONFIG_TARGET_IMAGES_GZIP
   define Image/Gzip
        rm -f $(1).gz