fix quilt variable and stampfile usage for host builds
[openwrt/staging/chunkeey.git] / include / quilt.mk
index fbb3e01e351d1c3b98bcdd6836b2a08cf5660117..32a62fb0df1eb1801993a91f5b07a1070448b248 100644 (file)
@@ -55,6 +55,10 @@ define PatchDir
 $(call PatchDir/$(if $(strip $(QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
 endef
 
+define HostPatchDir
+$(call PatchDir/$(if $(strip $(HOST_QUILT)),Quilt,Default),$(strip $(1)),$(strip $(2)),$(strip $(3)))
+endef
+
 ifneq ($(PKG_BUILD_DIR),)
   QUILT?=$(if $(wildcard $(PKG_BUILD_DIR)/.quilt_used),y)
   ifneq ($(QUILT),)
@@ -78,9 +82,9 @@ ifneq ($(HOST_BUILD_DIR),)
 endif
 
 define Host/Patch/Default
-       $(if $(QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
-       $(call PatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
-       $(if $(QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
+       $(if $(HOST_QUILT),rm -rf $(HOST_BUILD_DIR)/patches; mkdir -p $(HOST_BUILD_DIR)/patches)
+       $(call HostPatchDir,$(HOST_BUILD_DIR),$(HOST_PATCH_DIR),)
+       $(if $(HOST_QUILT),touch $(HOST_BUILD_DIR)/.quilt_used)
 endef
 
 define Build/Patch/Default