iproute2: update to 5.4.0
[openwrt/staging/chunkeey.git] / package / network / utils / iproute2 / patches / 175-reduce-dynamic-syms.patch
index d3f6a262d6c053467e457d29e509ececd2452b21..0385bd737b25602d7f90fa655efa21af486075ac 100644 (file)
@@ -1,6 +1,6 @@
 --- a/tc/Makefile
 +++ b/tc/Makefile
-@@ -110,7 +110,7 @@ LDLIBS += -L. -lm
+@@ -111,7 +111,7 @@ LDLIBS += -L. -lm
  
  ifeq ($(SHARED_LIBS),y)
  LDLIBS += -ldl
@@ -9,7 +9,7 @@
  endif
  
  TCLIB := tc_core.o
-@@ -140,7 +140,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
+@@ -141,7 +141,7 @@ MODDESTDIR := $(DESTDIR)$(LIBDIR)/tc
  all: tc $(TCSO)
  
  tc: $(TCOBJ) $(LIBNETLINK) libtc.a
@@ -18,7 +18,7 @@
  
  libtc.a: $(TCLIB)
        $(QUIET_AR)$(AR) rcs $@ $^
-@@ -162,6 +162,7 @@ install: all
+@@ -163,6 +163,7 @@ install: all
  clean:
        rm -f $(TCOBJ) $(TCLIB) libtc.a tc *.so emp_ematch.yacc.h; \
        rm -f emp_ematch.yacc.*
@@ -26,7 +26,7 @@
  
  q_atm.so: q_atm.c
        $(QUIET_CC)$(CC) $(CFLAGS) $(CPPFLAGS) $(LDFLAGS) -shared -fpic -o q_atm.so q_atm.c -latm
-@@ -201,4 +202,15 @@ static-syms.h: $(wildcard *.c)
+@@ -202,4 +203,15 @@ static-syms.h: $(wildcard *.c)
                sed -n '/'$$s'[^ ]* =/{s:.* \([^ ]*'$$s'[^ ]*\) .*:extern char \1[] __attribute__((weak)); if (!strcmp(sym, "\1")) return \1;:;p}' $$files ; \
        done > $@