brcm2708: organize kernel patches
[openwrt/staging/chunkeey.git] / target / linux / brcm2708 / patches-4.19 / 950-0508-BCM270X_DT-Create-bcm2708-rpi-zero.dts.patch
diff --git a/target/linux/brcm2708/patches-4.19/950-0508-BCM270X_DT-Create-bcm2708-rpi-zero.dts.patch b/target/linux/brcm2708/patches-4.19/950-0508-BCM270X_DT-Create-bcm2708-rpi-zero.dts.patch
deleted file mode 100644 (file)
index ff74b41..0000000
+++ /dev/null
@@ -1,148 +0,0 @@
-From e819b50b0c384f11f4eaf6e1ea76030c320f4511 Mon Sep 17 00:00:00 2001
-From: Phil Elwell <phil@raspberrypi.org>
-Date: Tue, 28 May 2019 16:23:51 +0100
-Subject: [PATCH 508/806] BCM270X_DT: Create bcm2708-rpi-zero.dts
-
-The Pi Zero deserves a dedicated .dtb file - sharing the b-plus .dtb
-has been observed to cause an issue with the MAC address of some
-Ethernet dongles.
-
-See: https://github.com/raspberrypi/linux/issues/2990
-
-Signed-off-by: Phil Elwell <phil@raspberrypi.org>
----
- arch/arm/boot/dts/Makefile             |   1 +
- arch/arm/boot/dts/bcm2708-rpi-zero.dts | 117 +++++++++++++++++++++++++
- 2 files changed, 118 insertions(+)
- create mode 100644 arch/arm/boot/dts/bcm2708-rpi-zero.dts
-
---- a/arch/arm/boot/dts/Makefile
-+++ b/arch/arm/boot/dts/Makefile
-@@ -4,6 +4,7 @@ dtb-$(CONFIG_ARCH_BCM2835) += \
-       bcm2708-rpi-b.dtb \
-       bcm2708-rpi-b-plus.dtb \
-       bcm2708-rpi-cm.dtb \
-+      bcm2708-rpi-zero.dtb \
-       bcm2708-rpi-zero-w.dtb \
-       bcm2709-rpi-2-b.dtb \
-       bcm2710-rpi-3-b.dtb \
---- /dev/null
-+++ b/arch/arm/boot/dts/bcm2708-rpi-zero.dts
-@@ -0,0 +1,117 @@
-+/dts-v1/;
-+
-+#include "bcm2708.dtsi"
-+#include "bcm283x-rpi-csi1-2lane.dtsi"
-+
-+/ {
-+      compatible = "raspberrypi,model-zero", "brcm,bcm2835";
-+      model = "Raspberry Pi Zero";
-+
-+      chosen {
-+              bootargs = "coherent_pool=1M";
-+      };
-+};
-+
-+&gpio {
-+      spi0_pins: spi0_pins {
-+              brcm,pins = <9 10 11>;
-+              brcm,function = <4>; /* alt0 */
-+      };
-+
-+      spi0_cs_pins: spi0_cs_pins {
-+              brcm,pins = <8 7>;
-+              brcm,function = <1>; /* output */
-+      };
-+
-+      i2c0_pins: i2c0 {
-+              brcm,pins = <0 1>;
-+              brcm,function = <4>;
-+      };
-+
-+      i2c1_pins: i2c1 {
-+              brcm,pins = <2 3>;
-+              brcm,function = <4>;
-+      };
-+
-+      i2s_pins: i2s {
-+              brcm,pins = <18 19 20 21>;
-+              brcm,function = <4>; /* alt0 */
-+      };
-+
-+      audio_pins: audio_pins {
-+              brcm,pins = <>;
-+              brcm,function = <>;
-+      };
-+};
-+
-+&uart0 {
-+      status = "okay";
-+};
-+
-+&spi0 {
-+      pinctrl-names = "default";
-+      pinctrl-0 = <&spi0_pins &spi0_cs_pins>;
-+      cs-gpios = <&gpio 8 1>, <&gpio 7 1>;
-+
-+      spidev0: spidev@0{
-+              compatible = "spidev";
-+              reg = <0>;      /* CE0 */
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+              spi-max-frequency = <125000000>;
-+      };
-+
-+      spidev1: spidev@1{
-+              compatible = "spidev";
-+              reg = <1>;      /* CE1 */
-+              #address-cells = <1>;
-+              #size-cells = <0>;
-+              spi-max-frequency = <125000000>;
-+      };
-+};
-+
-+&i2c0 {
-+      pinctrl-names = "default";
-+      pinctrl-0 = <&i2c0_pins>;
-+      clock-frequency = <100000>;
-+};
-+
-+&i2c1 {
-+      pinctrl-names = "default";
-+      pinctrl-0 = <&i2c1_pins>;
-+      clock-frequency = <100000>;
-+};
-+
-+&i2c2 {
-+      clock-frequency = <100000>;
-+};
-+
-+&i2s {
-+      pinctrl-names = "default";
-+      pinctrl-0 = <&i2s_pins>;
-+};
-+
-+&leds {
-+      act_led: act {
-+              label = "led0";
-+              linux,default-trigger = "mmc0";
-+              gpios = <&gpio 47 0>;
-+      };
-+};
-+
-+&hdmi {
-+      hpd-gpios = <&gpio 46 GPIO_ACTIVE_LOW>;
-+};
-+
-+&audio {
-+      pinctrl-names = "default";
-+      pinctrl-0 = <&audio_pins>;
-+};
-+
-+/ {
-+      __overrides__ {
-+              act_led_gpio = <&act_led>,"gpios:4";
-+              act_led_activelow = <&act_led>,"gpios:8";
-+              act_led_trigger = <&act_led>,"linux,default-trigger";
-+      };
-+};