ipq806x: add support for Arris TR4400 v2 / RAC2V1A
[openwrt/staging/chunkeey.git] / target / linux / ipq806x / image / generic.mk
index 819c73d338ceb83d866d31b6c585a0a3402a60f2..469f2c654e525a95dffe9f956fca95230bb39e7b 100644 (file)
@@ -65,6 +65,19 @@ define Device/ZyXELImage
                append-metadata
 endef
 
+define Device/arris_tr4400-v2
+       $(call Device/LegacyImage)
+       DEVICE_VENDOR := Arris
+       DEVICE_MODEL := TR4400
+       DEVICE_VARIANT := v2
+       SOC := qcom-ipq8065
+       BLOCKSIZE := 128k
+       PAGESIZE := 2048
+       DEVICE_PACKAGES := ath10k-firmware-qca9984-ct ath10k-firmware-qca99x0-ct
+       KERNEL_IN_UBI := 1
+endef
+TARGET_DEVICES += arris_tr4400-v2
+
 define Device/askey_rt4230w-rev6
        $(call Device/LegacyImage)
        DEVICE_VENDOR := Askey