replace the ugly rb532 cmdline hack with a cleaner one that does not depend on magic...
[openwrt/staging/chunkeey.git] / target / linux / rb532-2.6 / base-files.mk
diff --git a/target/linux/rb532-2.6/base-files.mk b/target/linux/rb532-2.6/base-files.mk
new file mode 100644 (file)
index 0000000..afd1220
--- /dev/null
@@ -0,0 +1,11 @@
+define Build/Compile
+       $(call Build/Compile/Default)
+       $(TARGET_CC) -o $(PKG_BUILD_DIR)/patch-cmdline $(PLATFORM_DIR)/src/patch-cmdline.c
+endef
+
+define Package/base-files/install-target
+       mkdir -p $(1)/sbin
+       $(CP) $(PKG_BUILD_DIR)/patch-cmdline $(1)/sbin
+endef
+
+