Fix the gpio handling and flash resource declaration, thanks to Daniel Gimpelevich
[openwrt/staging/chunkeey.git] / target / linux / rdc-2.6 / image / Makefile
index 0d53b26d0cf77d90f2b1a809d0e8a0dfd6c62115..74713e2d7d332a8798f888743b7b2ac70b87a9b3 100644 (file)
@@ -25,7 +25,7 @@ define Image/Build/ar525w
        touch $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-$(2).img
        mv $(KDIR)/root.$(1) $(KDIR)/root.tmp
        dd of=$(KDIR)/root.$(1) if=$(KDIR)/root.tmp $(call trxalign/$(1)) conv=sync
-       rm -f $(KDIR)/root.tmp
+       $(RM) -f $(KDIR)/root.tmp
        $(STAGING_DIR_HOST)/bin/airlink -b 1 -j $(shell bash -c 'echo $$[$(3)]') $(KDIR)/bzImage $(KDIR)/root.$(1) $(BIN_DIR)/openwrt-$(BOARD)-$(KERNEL)-$(1)-$(2).img
 endef