treewide: simplify inclusion of subtarget image files
[openwrt/staging/chunkeey.git] / target / linux / sunxi / image / Makefile
index 1b98849a5048dd1353864b86d51bf29e77a1d0a3..01e9742b4602a4e72d086a868fe995c98201d70a 100644 (file)
@@ -42,16 +42,6 @@ define Device/Default
   SUNXI_DTS = $$(SUNXI_DTS_DIR)$$(SOC)-$(lastword $(subst _, ,$(1)))
 endef
 
-ifeq ($(SUBTARGET),cortexa7)
-include cortex-a7.mk
-endif
-
-ifeq ($(SUBTARGET),cortexa8)
-include cortex-a8.mk
-endif
-
-ifeq ($(SUBTARGET),cortexa53)
-include cortex-a53.mk
-endif
+include $(SUBTARGET).mk
 
 $(eval $(call BuildImage))