toolchain/gcc: use ELFv2 ABI on ppc64 with musl
[openwrt/staging/chunkeey.git] / toolchain / gcc / common.mk
index a1950028883676329765129fd9d6dc0faf5a8871..bef4fa37f8f90466c304c4a3c836d4912ea5025f 100644 (file)
@@ -108,6 +108,7 @@ GCC_CONFIGURE:= \
                $(if $(CONFIG_mips64)$(CONFIG_mips64el),--with-arch=mips64 \
                        --with-abi=$(call qstrip,$(CONFIG_MIPS64_ABI))) \
                $(if $(CONFIG_arc),--with-cpu=$(CONFIG_CPU_TYPE)) \
+               $(if $(CONFIG_powerpc64), $(if $(CONFIG_USE_MUSL),--with-abi=elfv2)) \
                --with-gmp=$(TOPDIR)/staging_dir/host \
                --with-mpfr=$(TOPDIR)/staging_dir/host \
                --with-mpc=$(TOPDIR)/staging_dir/host \