gcc: optionally build gccgo compiler
[openwrt/staging/chunkeey.git] / toolchain / gcc / final / Makefile
index 3434d894a2b501ba9545c99d47066fc43a7b5480..01fec380273752d01c10046f476f785ec34b92aa 100644 (file)
@@ -39,7 +39,16 @@ define Host/Configure
        );
 endef
 
+ifeq ($(CONFIG_USE_GLIBC)$(CONFIG_INSTALL_GCCGO),yy)
+define FixGogccCrt
+       # link crtX.o for gotools
+       mkdir -p $(GCC_BUILD_DIR)/gotools
+       $(foreach crt, i 1 n, ln -sf ../../glibc-dev/lib/crt$(crt).o $(GCC_BUILD_DIR)/gotools/ ; )
+endef
+endif
+
 define Host/Compile
+       $(FixGogccCrt)
        +$(GCC_MAKE) $(HOST_JOBS) -C $(GCC_BUILD_DIR) all
 endef