gcc: musl comes with its own SSP, so use it instead of libssp
[openwrt/staging/chunkeey.git] / toolchain / gcc / final / Makefile
index 3fb5ccf83fe63466617c6045001284c0af354155..1212d145abd8bdf3a22fbf6a68d5d05dadeb81b4 100644 (file)
@@ -16,6 +16,10 @@ ifneq ($(CONFIG_GCC_VERSION_4_5)$(CONFIG_GCC_VERSION_4_6),)
        --with-libelf=$(TOPDIR)/staging_dir/host
 endif
 
+ifdef CONFIG_USE_MUSL
+  GCC_MAKE += gcc_cv_libc_provides_ssp=yes
+endif
+
 ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
   GCC_CONFIGURE += \
        --enable-sjlj-exceptions