introduce option to enable setjump()/longjump() based C++ exceptions (#9185, patch...
[openwrt/staging/chunkeey.git] / toolchain / gcc / final / Makefile
index 1decc951585044291f72e3626de2b7716862e1c7..337f7ab1c5deaa74aa3a9d389eb493bdb3765e00 100644 (file)
@@ -22,6 +22,11 @@ else
        --disable-tls
 endif
 
+ifneq ($(CONFIG_SJLJ_EXCEPTIONS),)
+  GCC_CONFIGURE += \
+       --enable-sjlj-exceptions
+endif
+
 define Host/Configure
        mkdir -p $(GCC_BUILD_DIR) $(TOOLCHAIN_DIR)/$(REAL_GNU_TARGET_NAME)
        # Important!  Required for limits.h to be fixed.