toolchain: remove leftovers from old llvm-gcc experiments
[openwrt/staging/chunkeey.git] / toolchain / llvm / patches / 110-darwin_version_detect.patch
diff --git a/toolchain/llvm/patches/110-darwin_version_detect.patch b/toolchain/llvm/patches/110-darwin_version_detect.patch
deleted file mode 100644 (file)
index 7fd62f9..0000000
+++ /dev/null
@@ -1,16 +0,0 @@
---- a/Makefile.rules
-+++ b/Makefile.rules
-@@ -506,11 +506,13 @@ endif
- #--------------------------------------------------------------------
- ifeq ($(HOST_OS),Darwin)
-+  ifndef DARWIN_VERSION
-   DARWIN_VERSION := `sw_vers -productVersion`
-   # Strip a number like 10.4.7 to 10.4
-   DARWIN_VERSION := $(shell echo $(DARWIN_VERSION)| sed -E 's/(10.[0-9]).*/\1/')
-   # Get "4" out of 10.4 for later pieces in the makefile.
-   DARWIN_MAJVERS := $(shell echo $(DARWIN_VERSION)| sed -E 's/10.([0-9]).*/\1/')
-+  endif
-   SharedLinkOptions=-Wl,-flat_namespace -Wl,-undefined -Wl,suppress \
-                     -dynamiclib