musl: update to 1.1.12 + git from 2016-01-22
[openwrt/staging/chunkeey.git] / toolchain / musl / patches / 200-add_libssp_nonshared.patch
index d0bf84541d864a761e2074cf8c791dacaa0c1f4a..0b97b346f8435b8572646788d1b9343bef10cf56 100644 (file)
@@ -12,30 +12,30 @@ Signed-off-by: Steven Barth <steven@midlink.org>
 
 --- a/Makefile
 +++ b/Makefile
-@@ -48,7 +48,7 @@ CRT_LIBS = lib/crt1.o lib/Scrt1.o lib/rc
+@@ -56,7 +56,7 @@ CRT_LIBS = lib/crt1.o lib/Scrt1.o lib/rc
  STATIC_LIBS = lib/libc.a
  SHARED_LIBS = lib/libc.so
  TOOL_LIBS = lib/musl-gcc.specs
 -ALL_LIBS = $(CRT_LIBS) $(STATIC_LIBS) $(SHARED_LIBS) $(EMPTY_LIBS) $(TOOL_LIBS)
 +ALL_LIBS = $(CRT_LIBS) $(STATIC_LIBS) $(SHARED_LIBS) $(EMPTY_LIBS) $(TOOL_LIBS) lib/libssp_nonshared.a
- ALL_TOOLS = tools/musl-gcc
+ ALL_TOOLS = obj/musl-gcc
  
  WRAPCC_GCC = gcc
-@@ -106,7 +106,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
+@@ -117,7 +117,8 @@ NOSSP_SRCS = $(wildcard crt/*.c) \
        src/env/__libc_start_main.c src/env/__init_tls.c \
        src/thread/__set_thread_area.c src/env/__stack_chk_fail.c \
        src/string/memset.c src/string/memcpy.c \
 -      src/ldso/dlstart.c src/ldso/dynlink.c
 +      src/ldso/dlstart.c src/ldso/dynlink.c \
-+      libssp_nonshared/__stack_chk_fail_local.c
- $(NOSSP_SRCS:%.c=%.o) $(NOSSP_SRCS:%.c=%.lo): CFLAGS += $(CFLAGS_NOSSP)
++      src/libssp_nonshared/__stack_chk_fail_local.c
+ $(NOSSP_SRCS:%.c=obj/%.o) $(NOSSP_SRCS:%.c=obj/%.lo): CFLAGS_ALL += $(CFLAGS_NOSSP)
  
- $(CRT_LIBS:lib/%=crt/%): CFLAGS += -DCRT
-@@ -155,6 +156,11 @@ lib/libc.a: $(OBJS)
+ $(CRT_LIBS:lib/%=obj/crt/%): CFLAGS_ALL += -DCRT
+@@ -161,6 +162,11 @@ lib/libc.a: $(OBJS)
        $(AR) rc $@ $(OBJS)
        $(RANLIB) $@
  
-+lib/libssp_nonshared.a: libssp_nonshared/__stack_chk_fail_local.o
++lib/libssp_nonshared.a: obj/src/libssp_nonshared/__stack_chk_fail_local.o
 +      rm -f $@
 +      $(AR) rc $@ $<
 +      $(RANLIB) $@
@@ -44,7 +44,7 @@ Signed-off-by: Steven Barth <steven@midlink.org>
        rm -f $@
        $(AR) rc $@
 --- /dev/null
-+++ b/libssp_nonshared/__stack_chk_fail_local.c
++++ b/src/libssp_nonshared/__stack_chk_fail_local.c
 @@ -0,0 +1,2 @@
 +#include "atomic.h"
 +void __attribute__((visibility ("hidden"))) __stack_chk_fail_local(void) { a_crash(); }